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WORD UNIT E
Objectives 1 -4

Creating and
Formatting Tables

Tables are commonly used to display information for quick reference and analysis. In this
unit, you learn how to create and modify a table in Word, how to sort table data and per-
form calculations, and how to format a table with borders and shading. You also learn how
to use a table to structure the layout of a page. 5% You are preparing a summary budget
for an advertising campaign aimed at the Chicago market. The goal of the ad campaign is
to promote winter tours to tropical destinations. You decide to format the budget informa-

tion as a table so that it is easy to read and analyze.

Insert a table

Insert and delete rows and columns
Modify rows and columns

Sort table data

Split and merge cells

Perform calculations in tables
Apply a table style

Create a custom format for a table
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Inserting a Table

A table is a grid made up of rows and columns of cells that you can fill with text and graphics. A cell is
the box formed by the intersection of a column and a row. The lines that divide the columns and rows
and help you see the grid-like structure of a table are called borders. You can create a table in a docu-
ment by using the Table command in the Tables group on the Insert tab. Once you have created a table,
you can add text and graphics to it. You begin by inserting a blank table and adding text to it.

QUICK TIP
Click the View Ruler
button at the top of
the vertical scroll bar
to display the rulers
if they are not
already displayed.

TROUBLE

Don't be concerned
if the paragraph
spacing under the
text in your table is
different from that
shown in the figures.

TROUBLE
If you pressed [Tab]
after the last row,
click the Undo but-

ton on the
Quick Access toolbar
to remove the new
blank row.

Start Word, click the View tab, then click the Page Width button in the Zoom group

2. Click the Insert tab, then click the Table button in the Tables group
The Table menu opens. It includes a grid for selecting the number of columns and rows you want the table
to contain, as well as several commands for inserting a table. Table E-1 describes the function of these com-
mands. As you move the pointer across the grid, a preview of the table with the specified number of
columns and rows appears in the document at the location of the insertion point.

3. Point to the second box in the fourth row to select 2x4 Table, then click
A table with two columns and four rows is inserted in the document, as shown in Figure E-1. Black borders
surround the table cells. The insertion point is in the first cell in the first row.

4. Type Location, then press [Tab]
Pressing [Tab] moves the insertion point to the next cell in the row.

5. Type Cost, press [Tab], then type Chicago Tribune
Pressing [Tab] at the end of a row moves the insertion point to the first cell in the next row.

6. Press [Tab], type 27,600, press [Tab], then type the following text in the table, pressing
[Tab] to move from cell to cell
Chicagotribune.com 25,000
Taxi tops 18,000

7. Press [Tab]
Pressing [Tab] at the end of the last cell of a table creates a new row at the bottom of the table, as shown in
Figure E-2. The insertion point is located in the first cell in the new row.

8. Type the following, pressing [Tab] to move from cell to cell and to create new rows
Chicago Defender 18,760

Hellochicago.com 3,250
Bus stops 12,000
Chicago Magazine 12,400

9. Click the Save button il on the Quick Access toolbar, then save the document as
Chicago Ad Budget to the drive and folder where you store your Data Files
The table is shown in Figure E-3.

TABLE E-1: Table menu commands

command

Insert Table

Draw Table

Convert Text to Table
Excel Spreadsheet
Quick Tables

use to

Create a table with any number of columns and rows and select an AutoFit behavior

Create a complex table by drawing the table columns and rows

Convert selected text that is separated by tabs, commas, or another separator character into a table
Insert a blank Excel worksheet into the document as an embedded object

Insert a table template chosen from a gallery of preformatted tables and replace the placeholder data with your own data
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FIGURE E-1: Blank table
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Chicago Tribune 27,600
Chicagotribune.com 25,000
Taxi tops 18,000
Chicago Defender 18,760
Hellochicago.com 3,250
Bus stops 12,000
Chicago Magazine 12,400]
 Converting text to a tat ‘ xt N _ ;
Another way to create a table is to convert text that is separated by table, select the text, click the Table button in the Tables group on
a tab, a comma, or another separator character into a table. For the Insert tab, and then click Convert Text to Table. In the Convert
example, to create a two-column table of last and first names, you Text to Table dialog box, select from the options for structuring and
could type the names as a list with a comma separating the last and formatting the table, and then click OK to create the table.
first name in each line, and then convert the text to a table. The sep- Conversely, you can convert a table to text that is separated by
arator character—a comma in this example—indicates where you tabs, commas, or some other character by selecting the table, click-
want to divide the table into columns, and a paragraph mark indi- ing the Table Tools Layout tab, and then clicking the Convert to Text
cates where you want to begin a new row. To convert text to a button in the Data group.
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Inserting and Deleting Rows
and Columns

You can easily modify the structure of a table by adding and removing rows and columns. First, you must click
or select an existing row or column in the table to indicate where you want to insert or delete a row or a col-
umn. You can select any element of a table using the Select command in the Table group on the Table Tools
Layout tab, but it is often easier to select rows and columns using the mouse. To insert or delete rows and
columns, you use the commands in the Rows & Columns group on the Table Tools Layout tab. &9 You
add new rows and columns to the table and delete unnecessary rows.

If the end of row

mark is not selected,
you have selected
only the text in the
row, not the row
itself.

You can also delete a

row or column by
pressing
[Shift][Delete].

QUICK TIP
To select a cell, place
the 4 pointer over
the left border of the
cell, then click.

—_

w

. Click the Home tab, then click the Show/Hide q button ] in the Paragraph group to

display formatting marks

An end of cell mark appears at the end of each cell and an end of row mark appears at the end of each row.
Click the Table Tools Layout tab, click the first cell of the Hellochicago.com row, then
click the Insert Above button in the Rows & Columns group

A new row is inserted directly above the Hellochicago.com row, as shown in Figure E-4. To insert a single
row, you simply place the insertion point in the row above or below where you want the new row to be
inserted, and then insert the row.

. Click the first cell of the new row, type Chicago Sun Times, press [Tab], then type 15,300

4. Place the pointer in the margin to the left of the Chicagotribune.com row until the

(%]

~N

8.

9.

10.

pointer changes to 7, click to select the row, press and hold the mouse button, drag
down to select the Taxi tops row, then release the mouse button
The two rows are selected, including the end of row marks.

. Click the Insert Below button in the Rows & Columns group

Two new rows are added below the selected rows. To insert multiple rows, you select the number of rows you
want to insert before inserting the rows.

. Click the Chicago Defender row, click the Delete button in the Rows & Columns group,

click Delete Rows, select the two blank rows, right-click the selected rows, then click
Delete Rows on the shortcut menu

The Chicago Defender row and the two blank rows are deleted. If you select a tow and press [Delete], you
delete only the contents of the row, not the row itself.

- Place the pointer over the top border of the Location column until the pointer changes

to ¥, then click
The entire column is selected.

Click the Insert Left button in the Rows & Columns group, then type Type
A new column is inserted to the left of the Location column, as shown in Figure E-5.

Click in the Location column, click the Insert Right button in the Rows & Columns group,
then type Details in the first cell of the new column
A new column is added to the right of the Location column.

Press [¥] to move the insertion point to the next cell in the Details column, click the
Home tab, click [%7] to turn off the display of formatting marks, enter the text shown in
Figure E-6 in each cell in the Details and Type columns, then save your changes

You can use the arrow keys to move the insertion point from cell to cell. Notice that text wraps to the next
line in the cell as you type. Compare your table to Figure E-6.
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FIGURE E-4: Inserted row
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FIGURE E-6: Text in Type and Details column
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Type Location Detalls Cost
Print Chicago Tribune 1full page, 1 time 27,600
Web Chicagotribune.com Animatedbanner, | 25000 Text wraps to
run of site, 1 million the next line
impressions.
Misc. Tax tops 60 taxis, 2 weeks 18,000
Print Chicago Sun Times Y page, 2 times 15,300
Web Hellochicago.com Tile, 100,000 3,250
Impressions
Misc. Bus stops 50 bus shelter 12,000
panels, 2 weeks
Print Chicago Magazine 2/3 page, 1 Issue 12,400

You can copy and move rows and columns within a table in the
same manner you copy and move text. Select the row or column
you want to move, then use the Copy or Cut button to place the
selection on the Clipboard. Place the insertion point in the location
you want to insert the row or column, then click the Paste button to

paste the selection. Rows are inserted above the row containing the
insertion point; columns are inserted to the left of the column con-
taining the insertion point. You can also copy or move columns and
rows by selecting them and using the B pointer to drag them to a
new location in the table.
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Modifying Rows and Columns

Once you create a table, you can easily adjust the size of columns and rows to make the table easier to read.
You can change the width of columns and the height of rows by dragging a border, by using the AutoFit
command in the Cell Size group on the Table Tools Layout tab, or by setting exact measurements using the
Table Row Height and Table Column Width text boxes in the Cell Size group or the Table Properties dialog
box. You adjust the size of the columns and rows to make the table more attractive and easier to
read. You also center the text vertically in each table cell.

QUICR TIP
Press [Alt] as you
drag a border to dis-
play the column
width or row height
measurements on
the ruler.

1. Position the pointer over the border between the first and second columns until the
pointer changes to [, then drag the border to approximately the %' mark on the
horizontal ruler
The dotted line that appears as you drag represents the border. Dragging the column border changes the
width of the first and second columns: the first column is narrower and the second column is wider. When
dragging a border to change the width of an entire column, make sure no cells are selected in the column.
You can also drag a row border to change the height of the row above it.

2. Position the pointer over the right border of the Location column until the pointer
changes to |, then double-click
Double-clicking a column border automatically resizes the column to fit the text.

3. Double-click the right border of the Details column with the +|* pointer, then double-
click the right border of the Cost column with the | pointer
The widths of the Details and Cost columns are adjusted.

4. Move the pointer over the table, then click the table move handle [#] that appears out-
side the upper-left corner of the table
Clicking the table move handle selects the entire table. You can also use the Select button in the Table group
on the Table Tools Layout tab to select an entire table.

5. Click the Home tab, then click the No Spacing button in the Styles group
Changing the style to No Spacing removes the paragraph spacing below the text in each table cell.

6. With the table still selected, click the Table Tools Layout tab, click the Distribute Rows
button [2 in the Cell Size group, then click in the table to deselect it
All the rows in the table become the same height, as shown in Figure E-7. You can also use the Distribute
Columns button to make all the columns the same width, or use the AutoFit button to make the width of
the columns fit the text, to adjust the width of the columns so the table is justified between the margins, or
to set fixed column widths.

7. Click in the Details column, click the Table Column Width text box in the Cell Size group,
type 3.5, then press [Enter]
The width of the Details column changes to 3.5".

8. Click the Select button in the Table group, click Select Table, click the Align Center Left
button [=l/in the Alignment group, deselect the table, then save your changes
The text is centered vertically in each table cell, as shown in Figure E-8. You can use the alignment buttons
in the Alignment group to change the vertical and horizontal alignment of the text in selected cells or in the
entire table.

QUICK TIP
Quickly resize a table
by dragging the
table resize handle
to a new location.

QUICK TIP

Quickly center a
table on a page by
selecting the table
and clicking the
Center button in the
Paragraph group on
the Home tab.
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FIGURE E-7: Resized columns and rows
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FIGURE E-8: Text centered vertically in cells
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Setting advanced table properties

When you want to wrap text around a table, indent a table, or set FIGURE E-9: Table Properties dialog hox
other advanced table properties, you click the Properties command T 3
in the Table group on the Table Tools Layout tab to open the Table
Properties dialog box, shown in Figure E-9. Using the Table tab in
this dialog box, you can set a precise width for the table, change the
horizontal alignment of the table between the margins, indent the
table, and set text wrapping options for the table. You can also click
Options on the Table tab to open the Table Options dialog box,
which you use to customize the table’s default cell margins and the
spacing between table cells. Alternatively, click Borders and Shading
on the Table tab to open the Borders and Shading dialog box, which
you can use to create a custom format for the table. The other tabs
in the Table Properties dialog box, the Column, Row, and Cell tabs,
allow you to set an exact width for columns, to specify an exact
height for rows, and to indicate an exact size for individual cells.
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Sorting Table Data

Tables are often easier to interpret and analyze when the data is sorted, which means the rows are organ-
ized in alphabetical or sequential order based on the data in one or more columns. When you sort a table,
Word arranges all the table data according to the criteria you set. You set sort criteria by specifying the col-
umn (or columns) by which you want to sort, and indicating the sort order—ascending or descending—
you want to use. Ascending order lists data alphabetically or sequentially (from A to Z, 0 to 9, or earliest
to latest). Descending order lists data in reverse alphabetical or sequential order (from Z to A, 9 to 0, or
latest to earliest). You can sort using the data in one column or multiple columns. When you sort by multi-
ple columns you must select primary, secondary, and tertiary sort criteria. You use the Sort command in the
Data group on the Table Tools Layout tab to sort a table. &35 You sort the table so that all ads of the
same type are listed together. You also add secondary sort criteria so that the ads within each type are listed
in descending order by cost.

QUICK TIP
To repeat the
header row on every
page of a table that
spans multiple
pages, click the
Repeat Header Rows
button in the Data
group on the Table
Tools Layout tab.

Word 112

1. Place the insertion point anywhere in the table
To sort an entire table, you simply need to place the insertion point anywhere in the table. If you want to
sort specific rows only, then you must select the rows you want to sort.

2. Click the Sort button in the Data group on the Table Tools Layout tab
The Sort dialog box opens, as shown in Figure E-10. You use this dialog box to specify the column or
columns by which you want to sort, the type of information you are sorting (text, numbers, or dates), and
the sort order (ascending or descending). Column 1 is selected by default in the Sort by list box. Since you
want to sort your table first by the information in the first column—the type of ad (Print, Web, or Misc.)—
you don't change the Sort by criteria.

3. Click the Descending option button in the Sort by section
The ad type information will be sorted in descending—or reverse alphabetical—order, so that the “Web” ads
will be listed first, followed by the “Print” ads, and then the “Misc.” ads.

4. In the first Then by section click the Then by list arrow, click Column 4, click the Type list
arrow, click Number if it is not already selected, then click the Descending option button
Within the Web, Print, and Misc. groups, the rows will be sorted by the cost of the ad—the information con-
tained in the fourth column, which is numbers, not dates or text. The rows will appear in descending order
within each group, with the most expensive ad listed first.

5. Click the Header row option button in the My list has section to select it
The table includes a header row that you do not want included in the sort. A header row is the first row of
a table that contains the column headings.

6. Click OK, then deselect the table
The rows in the table are sorted first by the information in the Type column and second by the information
in the Cost column, as shown in Figure E-11. The first row of the table, which is the header row, is not
included in the sort.

7. Save your changes to the document
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FIGURE E-10: Sort dialog box
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Sorting lists and paragraphs

In addition to sorting table data, you can use the Sort command to
alphabetize text or sort numerical data. When you want to sort data
that is not formatted as a table, such as lists and paragraphs, you use
the Sort command in the Paragraph group on the Home tab. To sort
lists and paragraphs, select the items you want included in the sort,
then click the Sort button. In the Sort Text dialog box, use the Sort
by list arrow to select the sort by criteria (paragraphs or fields), use
the Type list arrow to select the type of data (text, numbers, or
dates), and then click the Ascending or Descending option button
to choose a sort order.

When sorting text information in a document, the term “fields”
refers to text or numbers that are separated by a character, such as a
tab or a comma. For example, you might want to sort a list of
names alphabetically. If the names you want to sort are listed in
“Last name, First name” order, then last name and first name are
each considered a field. You can choose to sort the list in alphabeti-
cal order by last name or by first name. Use the Options button in
the Sort Text dialog box to specify the character that separates the
fields in your lists or paragraphs, along with other sort options.

Creating and Formatting Tables Word 113



